2025.6 release notes

November 2025

Continuous Data 2025.6.0.0 introduces SQL Server AG Fast Provision and Fast Refresh for dramatically faster, predictable VDB operations, and Incremental V2P for SQL Server and Oracle to enhance data recovery and business continuity in ransomware and disaster recovery scenarios. This release also adds Secure Boot support for Shielded VM instances on Google Cloud Platform, retires the legacy Self-Service (Jetstream) interface, and includes numerous bug fixes and API enhancements to improve performance, compliance, and manageability.

On this page:

New features

SQL Server AG Fast Provision and Fast Refresh

The Delphix Continuous Data Engine currently supports provisioning and refreshing Virtual Databases (VDBs) on SQL Availability Groups using a traditional backup-and-restore approach, where operation time depends on the size of the database.

With this release, we introduce Fast Provision and Fast Refresh, which eliminate the backup-and-restore step, resulting in significant performance improvements with consistent and predictable completion times.

Currently, the SQL Server availability group on target cluster environments or more specifically provisioning of VDBs into SQL Server availability groups is only available via the Command Line Interface (CLI).

For more information, read Provisioning a SQL Server AG Virtual Database.

Incremental V2P support in SQL Server and Oracle

Incremental V2P augments the existing Export workflow to enable seamless application continuity via complete recovery of production data in critical Ransomware and Disaster Recovery (DR) scenarios.

To ensure minimum downtime in case of a ransomware attack or a disaster recovery incident, an Incremental V2P operation can be initiated from a VDB which acts as a stand-in production. The operation creates a physical copy of the VDB while also tracking changes from the VDB, applying them to the physical database at configured intervals. This allows users to keep using the VDB as a stand-in production until the physical database catches up and becomes ready for a switchover with minimal downtime.

Currently, the Incremental V2P is supported only via API/CLI.
The support for Oracle Real Application Clusters (RAC) is not included in this release.

For more information, read Incremental V2P with SQL Server VDB and Incremental V2P for an Oracle dataset.

GCP Secure Boot support for Delphix engines

Delphix engines now support Secure Boot on Google Cloud Platform (GCP) through Google Cloud’s Shielded VM security features. Secure Boot adds an extra layer of protection against threats that can persist across reboots by ensuring instances only launch software signed with trusted cryptographic keys stored in the UEFI key database.

For more information, read Procedure for deploying in GCP.

GCP gVNIC support for Delphix engines

GCP support of Google Virtual NIC (gVNIC) which is the alternative to the virtIO based driver and is only supported network interface in Compute Engine for all new machine types (Generation 3 and newer). This feature is only supported on new Delphix engine installations.

For more information, read Deployment for Google Cloud Platform.

Support for multiple Oracle Key Vault clients per host (Preview)

Oracle Key Vault (OKV) is a software appliance for centrally managing encryption keys and security secrets across an enterprise's on-premises and cloud environments. It is designed to manage keys for Oracle databases, such as Transparent Data Encryption (TDE) master keys. Until now, Delphix only supported one OKV client per host. This means that all Oracle databases running on the same host must connect to the same OKV server through the same OKV client, resulting in a security limitation that multiple databases on the same host must share the same TDE wallets on the OKV appliance. In 2025.6, Delphix offers a CLI/API-only feature to support multiple OKV clients per host, which meets the needs of customers who require security separation between databases running on the same host.

Fixed issues

Release 2025.6.0.0 (November 2025)

Issue number Description
DLPX-39685 Improved error message to allow identifying the user if database linking fails due to an expired password.
DLPX-62662 Provided warning about increased space usage when replicating between engines with different block sizes.
DLPX-66771 Added the ability to add a source AG cluster environment on the Delphix Engine using domain accounts with minimum required permissions.
DLPX-91364 Fixed an issue where failures occurred with the error: exception.job.execute.internal but not with exception.host.toolkit.inaccessible when toolkit is not available on target host.
DLPX-91724 Fixed an issue where repository template creation incorrectly allowed CDB containers instead of PDB containers, causing VDB config templates to be ignored during provisioning.
DLPX-94080 Fixed an issue where a vPDB, already started outside Delphix Engine, was restarted when started from the Delphix Engine UI.
DLPX-94234 Oracle database parameter db_block_size is now user-configurable for the staging databases created by the Oracle Staging Push dSources.
DLPX-94270 Error log files generated by LogSync when delphix_rman_editor.sed script was used are now cleaned up from the Delphix toolkit directory.
DLPX-94435 Fixed an issue where Delphix Engine may report fault.system.reaper.unmount.failed in some conditions without any additional info on datasets that it failed to clean up.
DLPX-94554 Fixed an issue where Oracle virtual PDB enable job failed with an internal error during execution due to an earlier failed refresh job and missing parent snapshots for the virtual PDB and its virtual CDB.
DLPX-94673 Fixed an issue where support bundle generation could fail during redaction due to large sparse log file size.
DLPX-94780 Fixed an issue where Oracle vPDB provision/refresh operations failed with an internal error due to a failing v$containers query.
DLPX-94930 Fixed an issue where SSO readiness check could fail intermittently.
DLPX-94947 Fixed an issue where provisioning an Oracle vPDB from a standby TDE-enabled dSource to a point in time failed with exception.oracle.targetscripts.pdb.finalize.unplug.failed if datafiles were added between snapshots.
DLPX-95141 Fixed a defect that resulted in upgrade failures on systems that originated on versions 5.3 or older.
DLPX-95146 Fixed an issue where a failed vPDB provisioning validation (due to a failure to enable NFSv3 service or retrieving the NFS version) could leave an orphaned filesystem under rpool/public on the Delphix engine, potentially causing upgrades to fail.
DLPX-95169 Fixed an issue where OCI Vault provisioning/refresh/rollback failed with ORA-46653: cannot retrieve master key information.
DLPX-95472 Fixed an issue where scheduled replications did not execute after upgrades.
DLPX-95524 Fixed an issue where Oracle V2ASM job failed due to insufficient space in the specified ASM diskgroup. A new API parameter has now been introduced to allow skipping the available space check.
DLPX-95577 Fixed an issue where the Engine had an issue while starting up due to MSSQL temporary snapshots being cast incorrectly as Oracle.
DLPX-95602 Updated keymap setting mechanism for Ubuntu 24.04.
DLPX-95630 Fixed an issue where a snapshot was taken for multiple PDBs in a linked CDB at the same time and LogSync was not enabled, archived logs could have been missing in one of the snapshots, making those snapshot unprovisionable.
DLPX-95657 Fixed an issue where FluentD Plugin was failing to send syslog data on log rotation.
DLPX-95710 Fixed an issue where environment discovery failed to discover Oracle PDB configs on Oracle 12.1.0.1.

Known issues

Issue number Summary Workaround
DLPX-93860 Migrating a vCDB/vPDB to a host with a different timezone will result in all SnapSyncs failing. None
DLPX-95004 Virtual source enable may fail with exception.lifecycle.cannot.enable.with.null.timeflow exception if a previous refresh operation fails. None
DLPX-95341 OCI image is not available for 2025.5 due to cloud platform integration issues. For new engine deployments, install 2025.4 and upgrade to the latest release.
DPLX-95446 IBM cloud image is not available for 2025.5 due to cloud platform integration issues. For new engine deployments, install 2025.4 and upgrade to the latest release.
DLPX-95633 Provisioning an Oracle VDB on Exadata infrastructure fails for Oracle version 19.27 and later, as starting from Oracle 19.27, small pages (used by auxiliary database created by Delphix Engine) are not allowed on Exadata. None
DLPX-95777 Limited support for file mapping via CLI. To pass more than one file mapping, use tools such as Python script, Postman.
DLPX-95934 VDBs running on Solaris may fail to come online after upgrading to 2025.4.0.* or newer. Enable dNFS on affected Solaris VDBs.
DLPX-96059 When Incremental V2P is performed on the same host as the temporary production VDB, new data files added to the temporary production VDB will be removed from the VDB, resulting in data loss. Use different hosts for temporary production VDB and the V2P database.

API changes

In Delphix 2025.6.0.0, the new API version is 1.11.46. This section describes all API changes since API version 1.11.45 which was released with Continuous Data 2025.5.0.0. All URL paths are relative to /resources/json/delphix.

Updates

API object Path Type Name Change
HostNfsChecksParameters HostNfsChecksParameters Property mountPath Updated unixrestrictedpath mount path format.
BlobObjectStoreRepaveListParameters BlobObjectStoreRepaveListParameters Property endPoint Property endPoint removed from required parameter.

Additions

API object Path Type Name Change
Container database Operation exportFinalize
exportCleanup
New operations added.
about about Property engineType New HYPERSCALE engine type added.
IncrementalExportParameters NA API type IncrementalExportParameters New input parameters for Incremental Export added.
IncrementalExportParameters NA Property BackupFrequencyMinutes New input parameter property added.
MSSqlIncrementalExportBackupParams NA API type MSSqlIncrementalExportBackupParams Input parameters to configure backups while provisioning a SQL Server Incremental VDB.
MSSqlIncrementalExportDelphixStorageBackupParams NA API type MSSqlIncrementalExportDelphixStorageBackupParams Input parameters to configure backups on Delphix storage while provisioning a SQL Server Incremental VDB.
MSSqlDBContainerRuntime NA Property incrementalExportBackupWorkerStatus
incrementalExportRestoreWorkerStatus
New properties added.
MSSqlIncrementalExportBackupWorkerRuntime NA API type MSSqlIncrementalExportBackupWorkerRuntime Runtime property for Incremental export backup workers for MSSQL databases.
MSSqlIncrementalExportRestoreWorkerRuntime NA API type MSSqlIncrementalExportRestoreWorkerRuntime Runtime property for Incremental export restore workers for MSSQL databases.
MSSqlVirtualSource Source Property incrementalExportBackupParams New property added.
MSSqlIncrementalExportParameters NA API type MSSqlIncrementalExportParameters Input parameters to apply continuous changes while exporting a SQL Server Incremental VDB.
MSSqlExportFinalizeParameters NA API type MSSqlExportFinalizeParameters Input parameters to facilitate export-finalize requests for MSSQL database.
MSSqlExportFinalizeParameters NA Property maxAllowedBackupsPendingRestore
force
New input parameter and properties added.
ExportFinalizeParameters NA API type ExportFinalizeParameters Input parameters to facilitate the export finalization request for an MSSQL or Oracle database.
OracleExportDBTimeflowPointTransferStrategy NA Property invokeDatapatch New property added.
OracleExportPDBTimeflowPointTransferStrategy NA Property invokeDatapatch New property added.
OracleIncrementalExportRuntime OracleIncrementalExportRuntime API type OracleIncrementalExportRuntime Runtime information for Oracle Incremental Export operation.
OracleBaseSourceRuntime NA Property incrementalExportRuntime New property added.
RepaveEngineSummary RepaveEngineSummary Property engineType New HYPERSCALE engine type added.
system system Property secureBootEnabled New property added.

Deprecated and EOL features

End of life for Self-Service/Jetstream in Continuous Data

The Self-Service (Jetstream) UI, API, and CLI have been removed from releases 2025.6 and newer. This includes the equivalent dxtoolkit commands. To continue using Self-Service features, migrate to Data Control Tower’s Delphix Experience as soon as possible. To avoid any unintentional loss, the engine’s SUV check will error and will not proceed with the upgrade if there is any Self-Service configuration. You are free to stay on an older version of Continuous Data to continue using Delphix Self-Service. Delphix Support is available for basic questions. However, no patches or bug fixes will be provided.

For more information, read our Delphix End of Support announcement.